Tråd bedømmelse:
  • 0 Stemmer - 0 Gennemsnit
  • 1
  • 2
  • 3
  • 4
  • 5
metasploit under windows xp
15-01-2016, 03:18
#1
metasploit under windows xp
Hej derude
Jeg er i gang med at øve mig i fuzzing. Jeg følger denne video lektion:
https://www.youtube.com/watch?v=TTng0EKTCgQ
Men der opstår et problem, når jeg skal bruge kommandoen:
msfpescan
kan hverken køre scriptet inde i metasploit konsollen, eller som et ruby script:
ruby msfpescan
Har endda prøvet at installere cygwin, og der kan jeg heller ikke få det til at virke. Håber på at der er nogle herinde der måske ved hvordan jeg skal gribe problemet an.
Mvh
Find alle beskeder fra denne bruger
Citer denne besked i et svar
15-01-2016, 09:02
#2
RE: metasploit under windows xp
Du skal nok skrive hvilken fejl du får, ellers kan vi ikke hjælpe.
yolo
Find alle beskeder fra denne bruger
Citer denne besked i et svar
15-01-2016, 09:39
#3
RE: metasploit under windows xp
Nej, det kan jo i realiteten være et hav af fejl, der resulterer i at modulet ikke kører.
Har du brugt Metasploit før? Har du opdateret?

Jeg vil også råde dig til at tage et kig på American Fuzzy Lop, når du engang har selve teorien på plads.
Find alle beskeder fra denne bruger
Citer denne besked i et svar
15-01-2016, 17:33
#4
RE: metasploit under windows xp
Kører du Metasploit fra windows?
Det er sikkert en rigtig gammel version af Metasploit.
Hans video er fra 2011, så der er sket en hel del siden.
Backtrack findes heller ikke mere.
Men som de andre siger, så skal vi nok have en fejlbesked, før vi kan hjælpe. Også gerne den præcise kommando du skriver. :)
---
Writing a shellcode decoder stub in assembly is like talking gibberish in such a way that it is still perfectly intelligible. - iTick
Besøg denne brugers hjemmeside Find alle beskeder fra denne bruger
Citer denne besked i et svar
16-01-2016, 09:30
#5
RE: metasploit under windows xp
bruger Windows XP som mit "target system" og har installeret den nyeste metasploit framework under det. når jeg kører scrptet me ruby kommandoen, så giver den mig følgende output:

C:\metasploit\apps\pro\msf3>ruby msfpescan.rb
Bundler could not find compatible versions for gem "msgpack":
In Gemfile:
metasploit-framework (>= 0) ruby depends on
msgpack (>= 0) ruby
Could not find gem 'msgpack (>= 0) ruby', which is required by gem 'metasploit-framework (>= 0) ruby', in any of the sources.

når jeg kører det fra metasploit konsollen, ser det således ud:

msf > msfpescan
[*] exec: msfpescan

[-] Permission denied exec: msfpescan
msf >

okay MalcomeXL lyder spændende med American Fuzzy Lop, men lige nu prøver jeg bare at få styr på det basale, derfor irriterer der mig lidt at det program der ikke virker som det skal.
Find alle beskeder fra denne bruger
Citer denne besked i et svar
16-01-2016, 17:12
#6
RE: metasploit under windows xp
Du skal nok installere den Ruby gem der hedder "msgpack". Der er en del på google om det.
Ellers skal du fri dig selv for alle problemerne, og køre Linux. :D
Når du arbejder på en windows box, kan du jo stadig lave ssh eller lign. til din linux box, så du ikke skal sidde og hoppe frem og tilbage. :)
---
Writing a shellcode decoder stub in assembly is like talking gibberish in such a way that it is still perfectly intelligible. - iTick
Besøg denne brugers hjemmeside Find alle beskeder fra denne bruger
Citer denne besked i et svar
10-08-2016, 08:18
#7
RE: metasploit under windows xp
har du prøvet at updatere din database?
prøv at kør
root@kali:~# service postgresql start
root@kali:~# msfdb init
root@kali:~# msfconsole
msf > db_status

jeg håber det hjælper. er i øjeblikket på ny hardware og har endnu ikke fået sat Kali op i en duel boot, så kan ikke bekræfte 100% at det virker men.. Good luck~
Find alle beskeder fra denne bruger
Citer denne besked i et svar
« Ældre | Nyere »




User(s) browsing this thread: 1 Gæst(er)